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Chapter 8 

Referencing Other Worksheets  

and Using Templates 
A workbook can contain many worksheets and information that is needed to complete one worksheet can be 

retrieved from data stored on another worksheet. Special functions in Excel retrieve data from tables in other 

worksheets based on a reference number or product name. Worksheets can be designed to be used repeatedly 

with formulas and other areas of the worksheet protected from accidental change and saved in a format that 

meets company standards. These files are usually designed to handle a task that must be done repeatedly such 

as filling out a time card, invoice, billing statement, or shipping statement. Creating a standardized worksheet 

for tasks that are preformed repeatedly saves time and creates a uniformity of appearance for the company. It 

can also be designed to minimize the risk of errors. 

Why Do I Need to Know This? 

Productivity and efficiency in the workplace is critical to create or maintain a competitive edge. To do this 

companies typically standardize repetitive tasks and establish procedures which will help to minimize errors. 

The image of a company is also controlled by establishing standards for how a company’s name and address 

is to be displayed, both in the typeface, font size and color that is used. All of these practices affect forms that 

may be used within a company or sent by a company to various vendors or customers. Automating repetitive 

tasks helps to create a more efficient process. In this chapter you will learn how to improve your productivity 

and accuracy on repetitive tasks and how you can help others do the same. This will make you a more 

valuable employee and a valuable co-worker who helps people save time and effort.  

1 Using Related Worksheets 

Learning Objectives 
1. Identify references to cells in other worksheets [8.1.1] 



   

 

Copyright ©2011 – John Preston Page 2 
 

2. Use named ranges in formulas and functions. [8.1.2] 

3. Identify methods of naming ranges of cells and limiting their scope. [8.1.3] 

4. Identify rules and methods for validating inputs. [8.1.4] 

5. Identify rules and methods for using VLOOKUP, LOOKUP, and HLOOKUP functions. [8.1.5] 

6. Identify how functions can be nested. [8.1.6] 

One of the strengths of a database management system is that it can bring together data from several related 

tables into a single form but the ability of a DBMS to do calculations is limited. Excel has more options for 

calculations but its ability to bring in data from related tables is limited. For an application where calculations 

are most important and only a few related tables are used, Excel is the appropriate choice. In this section, you 

learn about retrieving data from related tables that might be on other worksheets. 

References to Cells in Other Worksheets 

A spreadsheet file in Excel is called a workbook. Individual spreadsheets are called worksheets or just sheets. 

A workbook consists of several worksheets and the names of the worksheets are displayed on tabs at the 

bottom of the window. The names of the worksheets can be edited to make them more meaningful, as shown 

in Figure 8.1. 
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Figure 8.1. Workbooks consist of worksheets 

A formula in one worksheet can refer to a cell in another sheet if the name of the worksheet is 

included in the reference. If a workbook has two worksheets—Invoice and Catalog—a formula in the Invoice 

sheet that refers to a particular cell on the Catalog sheet,  might be =Catalog!D4 where the name of the 

worksheet is included in the reference followed by an exclamation mark, as shown in Figure 8.2.  

 

Figure 8.2. Formula refers to cell D4 on the Catalog worksheet that contains a part code 

Like other relative cell references, it can be copied or filled. The relative reference to the cell in the 
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other worksheet will change. For example, if a reference to cell D4 in the Catalog sheet is filled or copied 

down one row, the reference changes to =Catalog!D5. 

Absolute references to cells in another worksheet use dollar signs to the left of the column letter and 

row number. For example, =Catalog!$D$4 will not change when filled or copied. 

Naming Cells and Groups of Cells 

Including worksheet names in the cell reference causes formulas to become much longer and harder to 

interpret or to recognize errors. A solution to this problem is to assign a meaningful name to a cell or a group 

of cells. The value in cell D4 in the Catalog worksheet is the price of a brass bushing. If cell D4 in the 

Catalog worksheet is given the name Bushing_Price the formula would be =Bushing_Price as shown in 

Figure 8.3. 

 

Figure 8.3. Name used as a cell reference. 

A cell name is an absolute reference. If the formula is copied or filled, the reference remains fixed on 

cell D4—named Bushing_Price in the Catalog worksheet. 

Groups of cells can be given a name. This is most useful when a formula or function uses a range as 

one of its arguments. For example, if a SUM formula will add cells E3:E20 on a worksheet named Orders, 

the formula might be =SUM(Orders!E3:E20). If an absolute reference is needed it would be 

=SUM(Orders!$E$3:$E$20). If the group of cells from E3 through E20 is given a single name, such as 

Friday_Orders, the formula would be =SUM(Friday_Orders). 

There are three convenient ways to name a cell or group of cells. They are: 

 Select the cell(s) and type the name in the Name box on the Formula bar. 

 Select a group of cells that contain labels in one column and values in the adjacent column, 
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and then choose Create from Selection to assign the labels to the cells as names. 

 Select the cell(s) and use the Define Name dialog box. 

The first two methods create names that can be used between worksheets. In some cases, this feature 

is not desirable. For example, if a worksheet is copied, so are its named ranges which create duplicates. 

Formulas within each cell refer to the appropriate location within the workbook but formulas in other 

worksheets might refer to the wrong cell.  

To specify where the name can be used, the name can be created using the Define Name dialog box. 

The Scope option can be used to share the name throughout the workbook or limit its use to a single 

worksheet as shown in Figure 8.4. 

  

Figure 8.4. Cell references between worksheets. 
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Summary Worksheets in a Workbook 

Because Excel has many calculation and charting options, it is often used to prepare a final report or 

summary of financial transactions that draw data from several tables. Creating an invoice for goods sold to a 

customer is a good example of this type of use. If the invoice is on its own worksheet, it can be printed by 

itself to be sent to a customer. The formulas in the invoice sheet can refer to tables of prices and charges on 

other sheets that are not printed. 

For example, a small company in the Midwest sells equipment that is used to provide homes with hot 

water that is heated by sunlight. A worksheet has been created to calculate the total cost of purchasing a 

system. It has been designed to list the individual components, discounts, taxes, shipping costs, and a final 

price, as shown in Figure 8.5. 
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Figure 8.5. Summary of costs and charges. 

Validating Data Input 

One of the challenges of managing data is consistently using the same spelling and spacing for descriptions 

or codes so that those descriptions or codes can be used to sort, filter, or count the items. One way to ensure 

that items are entered consistently is to require the user to pick from an approved list instead of typing. 
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Assuring consistency and accuracy of data input is called validation. A list of acceptable values or ranges of 

acceptable numeric values can be specified. A range of cells that contain acceptable values can be used to 

lookup the item. For example, a catalog of parts for solar hot water heaters is stored as a worksheet named 

Catalog, as shown in Figure 8.6. 

 

Figure 8.6. Data from another sheet can be used to validate input. 

On the Sales Invoice sheet, in the description column, a link can be established between the cell and 

the named range of descriptions so that the user clicks one of the names on the list instead of typing the 

description, as shown in Figure 8.7. 
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Figure 8.7. Named range used to create a menu of choices to assure accurate input. 

Retrieving Data from Other Worksheets 

If a list of data is arranged like a database table and one of the columns contains unique values like those in 

the key field in a database table, then the list can be searched for values that can be inserted into cells or used 

in formulas. If a parts catalog has a unique description for each item, the catalog can be searched for that 

description and then a value from the same row—similar to a record in a database—can be used. The 

function in Excel that performs this search is the LOOKUP function. For example, if the part description has 

been chosen, it can be used to look up the part number, as shown in Figure 8.8. 
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Figure 8.8. LOOKUP function finds values in a range of data. 

In some cases the number or word to be looked up is not an exact match with the data in the 

designated range of data. For example, to find the cost of shipping, the program must first determine the 

shipping zone. The zones are based on the location of the shipper from the postal code of the destination. 

Instead of listing all the possible postal codes in the country, they are divided into ranges. For example, if the 

company is located in postal code 48197, the shipping zones for the rest of the country are shown in Figure 

8.9. 
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Figure 8.9. Range must have a first column of unique values that are sorted. 

The VLOOKUP function finds data that is in a table that has unique values in the first column that are 

sorted in ascending order. The function compares the value to be looked up with each value in the first 

column using the <= (less than or equal to) comparison and remembers the rows for which this is True. When 

it comes to a row where the comparison is False, it assumes that the previous row is the best match. For 

example, if the ZIP code to look up was 15000, the program would compare 15000 to each value in column 

B and note that each is True until it comes to the row with 16300 where the comparison is False. The 

program chooses the last row for which the comparison was true, which would be 14900.  

The VLOOKUP function has three arguments;  

 value to lookup  

 range in which to look  

 column number where the desired value is stored 

The range of cells in which to look is a group of cells that has two or more columns. The first column 

must contain a sorted list of unique values. The column number refers to the column in the selected group of 

cells, as shown in Figure 8.10. 

 

Figure 8.10. Range used with a VLOOKUP function. 
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For example, a VLOOKUP function can be used to find the shipping zone for a destination with a 

given ZIP. The program begins with the value in cell G36 (15000), searches the data in the range named 

Postal_Codes, and then returns the value from the second column in the row that was the last to match the 

comparison operator, as shown in Figure 8.11. 

 

 Figure 8.11.VLOOKUP function finds shipping zone. 

If the range of data is stored horizontally, a similar function named HLOOKUP will search the range 

of cells assuming that the first row is sorted in increasing order and return the value from the specified row. 

For example, the company offers a discount for amounts greater than or equal to $500. The amount of 

discount increases depending on the subtotal of the order. The amount of discount is in a range named 

Discount, on the Pricing worksheet as shown in Figure 8.12. 
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Figure 8.12. Discounts based on the subtotal of the invoice. Table oriented horizontally. 

To find the discount on an order with a subtotal of $3,341.80, the HLOOKUP function searches the 

first row of the Discount range and concludes that $1,000 is the last item in the first row for which the <= 

comparison is True and then returns the value in second row (10%). The value (10%) from the HLOOKUP 

function can be used in a formula where it is multiplied by the subtotal to determine the discount amount, as 

shown in Figure 8.13. 

 

Figure 8.13. The HLOOKUP function used for data arranged horizontally. 
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The lookup functions can be combined. For example, the shipping charge is based on the total weight 

of the order and the zone to which the parts will be shipped. The table of data can be designed so that the 

result of a previous lookup can be used as an argument in another lookup function. The zone number from 

the Postal_Codes lookup can be used as the column number in the lookup used to find the shipping charge, as 

shown in Figure 8.14. 

 

Figure 8.14. Shipping charge per pound based on weight and delivery zone. 

 The zone number found previously can be used as an argument in the VLOOKUP function used to 

find the shipping charge in cell G38, as shown in Figure 8.15. 
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Figure 8.15. Shipping cost is the product of the charge per pound and the total weight. 

Alternatively, the two steps could be combined in one function. When a function or formula is used as 

an argument of another function, the practice is called nesting. The formula in cell G38 could replace the 

reference to cell G37 with the function in that cell, as shown in Figure 8.16. 

 

Figure 8.16. Nested functions. 

 

Key Takeaways 
 Excel files are called workbooks. They are divided into worksheets. Data can be stored in the cells of a worksheet. 

References to cells in other worksheets include the sheet name followed by an exclamation point and the cell 
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address.[8.1.1] 

 Rows, columns, or ranges of cells can be given names that can be used in formulas or functions in place of the cell 

addresses. [8.1.2] 

 Ranges or cells whose names might be used from any sheet in the workbook can be named by selecting the range 

and typing the name in the Name box on the Formula Bar. Labels that are adjacent to the cells can be used as cell 

names by selecting both and using the Create from Selection option. To limit the scope of a name to a particular 

worksheet, use the Define Name option. [8.1.3] 

 Data entry can be restricted to acceptable values or exact spelling of words by defining what is acceptable or by 

providing a list of acceptable values. When exact matches are important for sorting, counting, or looking up data, 

a list of approved text or numbers can be provided as a named range. The range is used to provide a menu of 

options from which to choose to assure consistent input. [8.1.4] 

 Lookup functions are used to help retrieve data from another table. The VLOOKUP function looks for a match in 

the first column proceeding from top to bottom. The LOOKUP function is similar but it can look up values in other 

columns. Both use the comparison operator <= and choose the last row for which the comparison is true. The 

function returns the value from the specified column in that row. The HLOOKUP function is similar except it 

works for data that is oriented horizontally. In general, use the LOOKUP function if the key data field is not in the 

first column. [8.1.5] 

 A function can be used as the argument of another function. This practice is called nesting. [8.1.6] 

2 Create a Form that Uses Data from Related 
Worksheets 

Learning Objectives 
1. Create a validation list from a named range. [8.2.1] 

2. Retrieve data from other worksheets using the LOOKUP, VLOOKUP, and HLOOKUP functions. 

[8.2.2] 

3. Fill lookup formulas and remove error codes [8.2.3] 

4. Retrieve data from other worksheets using a Nested lookup. [8.2.4] 

5. Share workbook with others. [8.2.5] 
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Forms can be designed to accomplish a particular purpose and then reused for repetitive activities, such as 

preparing invoices, ordering supplies, paying vendors and so forth. Using a standardized form insures 

consistency of layout and style and a uniform image for the company. In this portion of the application you 

will use a worksheet that looks up related data from other worksheets to prepare an invoice. 

Naming Column Ranges from Selection 

A single cell or a range of cells can be named and then the name can be used in a formula. Named ranges 

work like an absolute cell reference. When data that you want to reference in a formula is on another 

worksheet, you can use the named range rather than clicking the other worksheet and selecting the range of 

cells to use in the formula. In the first part of this exercise you will name cells in a table of data based on the 

column heading. 

1. Start Excel, and from the folder where the files for this class are located, open Ch08Templates.xlsx file. 

Save the file as Ch08TemplatesStudentName. Click the Catalog sheet tab. Click in cell A3. Use the 

vertical scroll bar to scroll to the end of the data on row 53, hold down the Shift key and then click cell 

D53 to select the entire table. This sheet contains a list of available parts that includes the part number, 

description, weight, and price of each item.  

2. On the Formulas tab, and in the Defined Names group, click the Create from Selection button.  

3. In the Create Names from Selection dialog box, click to remove the arrow from the Left column check 

box and be sure that the Top row check box is selected as shown in Figure 8.17.  
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Figure 8.17. Top row will be used to name the ranges. 

4. Click OK. Click the Name Box list arrow to display the list of named ranges as shown in Figure 8.18, and 

then click Description to confirm that the range B4:B53 is named Description. The range of cells that has 

been named shows as being selected. 

 

Figure 8.18. Range names display in Name Box list. 

Creating a Validation List in a Template 

To ensure that the data entered in the invoice is consistent and accurate you will create a validation list for 

the Description field on the invoice. 

1. In your Ch08TemplatesStudentName file click the Invoice sheet tab. Click in cell B11 and replace Name 

with your name. 

2. Click cell A22 and notice that cell this is merged with cell B22. This was done to create an area on the 

template that would be wider for the description field. 

3. On the Data tab, in the Data Tools group click the Data Validation button. 

4. In the displayed Data Validation dialog box, on the Settings tab, click the Allow arrow and then click 

List. In the Source box type =Description and then compare your results with Figure 8.19. 
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Figure 8.19. A validation list is created to use the Description named range 

5. Click the Input Message tab. In the Input message box type Select an item from the list and then click 

OK. 

6. In cell A22, notice that a list arrow displays along with the message that you typed in the Input Message 

box.  

7. In cell A22, point to the fill handle and then drag the fill handle down to cell A30 to fill the validation list 

format to the other cells in this column. Click on the cells in this range to verify that a list arrow displays 

along with the input message. Save your work. 

Retrieving Data from Other Worksheets Using the Lookup Function 

To ensure that the rest of the fields are completed correctly lookup functions will be used to retrieve data 

from the Catalog, Pricing, and Zones worksheets. To retrieve the part number, the LOOKUP function will be 

used because the data that is being looked up—the description—is not in the first column of the catalog table. 

1. In cell A22, click the list and then select Cap, copper from the list.  

Tip: While we are adding the lookup fields to the other columns it is helpful to have a valid value in cell 
A22 so that you can see if your results are working as expected. If cell A22 was empty, then the lookup 
functions would return the error message #NA because there would not be a valid value to lookup. 
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2. Click cell C22. On the Formulas tab, in the Function Library group, click the Lookup & Reference 

button, and then click LOOKUP from the list of available functions. 

3. In the Select Arguments dialog box, be sure the first option is selected: lookup value, lookup vector, 

result lookup, and then click OK. 

4. In the Function Arguments dialog box, in the Lookup value box type A22 and then press Tab. 

5.  In the Lookup vector box type Description, press Tab, and then in the Result vector box type 

Part_Number. Compare your dialog box with Figure 8.20. 

 

Figure 8.20. Lookup function used to retrieve the part number 

6. Click OK. Verify that CC-0027 displays in cell C22. This is the part number for the Cap, copper item. 

7. Click cell D22 and type 10 for the quantity, and then press Tab.  

8. In Cell E22, repeat steps 3 and 4 to display the LOOKUP function argument dialog box. 

9. In the Lookup value box type A22, in the Lookup vector box type Description, and in the Result Vector 

dialog box type Price. Click OK. Verify that in cell E22, 2.95 displays as the price. 

10. Click cell F22 and repeat the steps you have practiced previously to use the LOOKUP function to retrieve 

the weight based on the description found in cell A22. 

11. In the Formula Bar, click at the end of the LOOKUP function and type *D22 to multiply the results by 
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quantity in cell D22. 

12. In cell G22 type =D22*E22 to calculate the total price. Format the cell with the Accounting Number 

Format. Notice that the Accounting format places the dollar sign at the far left of the cell. Compare your 

results to Figure 8.21.  

 

 

Figure 8.21. Lookup functions used to retrieve price and weight. 

13. Click cell G31 and on the Formulas tab, in the Function Library, click the AutoSum button. Confirm that 

the range to sum is G22:G30 and then click the button a second time, or press Enter to confirm the 

formula. 

14. Click cell G33, type 6% for the Tax Rate, and then press Enter. 

Retrieving Data from Other Worksheets Using the VLOOKUP Function 

The VLOOKUP function is used when the data is arranged in a vertical table and the lookup value is found 

in the first column of the table. It is best if the table is first sorted in ascending order by the key field—the 

lookup value. You will begin by naming the table array used in the VLOOKUP function. 

1. Click the Zones sheet tab. Click cell B3, and then use the vertical scroll bar to scroll until you can see the 

bottom of the list. Hold down the Shift key, and then click cell C117. This selects all of the data in the 

range, B3:C117. 

Tip: When you select part of a table to name with the intention of using it as an argument in a VLOOKUP 
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function, do not include the column labels in the first row. 

2.  On the Formulas tab, in the Defined Names group, click the Define Name button. In the New Name 

dialog box, in the Name box confirm or type ZIP_Code  Confirm that the Refers to box displays 

=Zones!$B$3:$C$117,  and then click OK. This names the two columns of data on this worksheet.  

3. Click the Name Box list arrow and verify that ZIP_Code displays as a named range.  

Tip: The name for the ZIP Code field uses an underscore between the two words because spaces are not 
valid characters when naming a range. Range names cannot contain spaces, # signs, or be the same as a 
cell address. Valid characters for a named range include letters, numbers, underscores or periods. 

4. Click the Name Box list arrow to close the list. 

5. Click the Invoice sheet tab and click cell G37. Here you will enter a VLOOKUP function to retrieve the 

shipping zone based on the zip code for the shipping address.  

6. On the Formulas tab, in the Function Library group, click the Lookup & Reference button. At the end of 

the displayed list click VLOOKUP. 

7. In the VLOOKUP dialog box, click in the Lookup_value box and then click cell G36—ZIP Code. Press 

Tab, and in the Table array box type ZIP_Code  Press tab and in the Col_index_num box type 2  

Compare your results with Figure 8.22. 

 

Figure 8.22. Vertical lookup used to retrieve the Shipping zone code 
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8. Click OK. #N/A displays as the result because the lookup field—cell G36—is empty. 

9. Click cell G36, type 35763 and press Enter. The shipping zone 4 displays in cell G36. 

10. In cell, G11, type Grace Murray. In G12, delete Company Name. In G13, type 1003 Treyburne. In G14, 

type Owens Crossroads, AL 36573 and in G15, type 856-555-1567. 

11. Recall that the RIGHT function can extract text from the right side of a field. In G36, type 

=RIGHT(G14,5) and then on the Formula Bar, click the Enter button. Observe that the RIGHT function 

displays the ZIP code but the function in G37 still displays the #N/A error. Recall that the VALUE 

function can be used to convert text to numbers. 

12. In G36, edit content or type =VALUE(RIGHT(G14,5)) and then press Enter. Observe that the LOOKUP 

function in cell G37, retrieves the shipping zone—4—correctly. 

13. Use the Format Painter to copy the fill color from G35 to G36 and G37 to indicate that these cells are not 

for user input. Select cells G36:G37 and apply the Number format with no decimal places or commas and 

then apply the Center format to these cells. Save your work. 

Retrieving Data from Other Worksheets Using the Hlookup Function 

The HLOOKUP function is used when the data that is being looked up is arranged in a horizontal table and 

the lookup value is found in the first row of the table. It is best if the table is first sorted in ascending order 

(from left to right) by the lookup value.  

1. Click the Pricing tab and exam the Quantity Discount table. The discount is calculated based on the total 

order. Notice that the subtotal amounts are arranged horizontally in row 4 in ascending order from left to 

right. 

2.  Select the range C4:F5. On the Formulas tab, in the Defined Names group, click Define Name. In the 

New Name dialog box, in the Name box type Discount. Confirm that the Refers to box displays 

=Pricing!$C$4:$F$5, and then click OK or press Enter to confirm the new named range.  
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Tip: When you select part of a table to name with the intention of using it as an argument in a HLOOKUP 
function, do not include the row labels in the first column. 

3. Click the Name Box list arrow and confirm that Discount display as a named range. 

4. Click the Invoice tab and click cell G32. On the Formulas tab, in the Function Library group, click the 

Lookup & Reference button, and then click HLOOKUP from the list. 

5. In the Lookup value box type G31, in the Table array box type Discount, and in the Row index num box 

type 2. Compare your results with Figure 8.23. 

 

Figure 8.23. Horizontal lookup used to retrieve discount 

6. Click OK. Format cell G32 with the Accounting Number Format. The Discount box displays a dollar sign 

and a dash. Our sample data is not sufficient to warrant a discount. To test this further more sample data 

needs to be added. 

Filling Lookup Formulas and Removing Error Codes 

The lookup function used in the first row of the invoice needs to be filled to the other rows so that the part 

number, price, and weight will be retrieved from the catalog when additional items are ordered. When you do 

this, the #NA error code will display if there is no item listed in column A. To remove the error code you will 

use the IFERROR function to hide an error code.  

1. Click cell A23, and from the list select Collector bracket set, 24" leg and then press Enter. In cell A24 
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select Solar collector panel, 4' X 10' and press Enter. 

2. Click cell C22 and use the fill handle to fill the lookup function in cell C22 down the column to cell C30. 

In the first two rows a part number displays based on the data entered in the Description column. In cells 

C25:C30 the error code #NA displays because there is no value in column A to lookup. 

3. Click cell C22. In the Formula Bar, click to place the insertion point between the = and LOOKUP and 

type IFERROR(  

4. Click at the end of the function after the closing parenthesis and type ,"") and then on the Formula bar 

click the Enter button . Compare your results with Figure 8.24. 

 

Figure 8.24. IFERROR Function used to remove error code when cell is empty. 

Tip: The IFERROR function is used to remove the #NA error code when a cell is empty. This is nested 
around the LOOKUP function. The first argument in the IFERROR function is to display the result of the 
LOOKUP function, the second argument is the double quote marks. The double quotes cause the cell to 
appear empty by displaying nothing in the cell rather than the error code. The basic logic is if the first 
argument is true (the LOOKUP function has a valid result) display the result, if the first argument is not 
true and an error code would display, then instead display nothing. 

5. With cell C22 as the active cell, point to the fill handle and drag the fill handle down to cell C30 to fill 

the new nested function. The #NA error codes no longer display in column C. 

6. Click cell E22 and modify the LOOKUP function so that it is nested inside the IFERROR function as 

shown in Figure 8.25. 
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Figure 8.25. IFERROR Function nested around price lookup function. 

7. Click cell F22 and repeat this process, and then compare your results with Figure 8.26 

 

Figure 8.26. IFERROR Function nested around weight lookup function. 

8. Click cell G22 and nest the IFERROR function around the calculation to determine the cost as shown in 

Figure 8.27. 

 

Figure 8.27. IFERROR Function nested around quantity x price calculation. 

9. Select cells E22:G22. Point to the fill handle in cell G22 and drag down to row 30 to fill the three 

formulas down the column. This will ensure that the #NA error does not display when a cell is empty. 

10. In cell D23 type 4 and in cell D24 type 4. The Unit Price, Weight, and Amount columns are filled in and 

the new subtotal is calculated to be $4,481.54. Compare your results with Figure 8.28. Save your work. 
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Figure 8.28. New subtotal calculated and error codes removed. 

11. Click cell G32. Notice that the discount displays as $0.10. The discount should be 10% of the subtotal. 

To calculate the correct discount, in the Formula Bar, click at the end of the HLOOKUP function and 

type *G31 which multiplies the discount that was looked up by the subtotal, and then click the Enter 

button, . Compare your results with Figure 8.29. 

 

Figure 8.29. Discount amount calculated. 

12. Click cell G34 and calculate the sales tax. Type = (G31-G32)*G33. Format the cell to Accounting 

Number Format. Save your work 

Retrieving Data from Other Worksheets Using a Nested Lookup  

Lookup functions can be combined. For example, the shipping charge is based on the total weight of the 

order and the zone to which the parts will be shipped. The table of data can be designed so that the result of a 

previous lookup can be used as an argument in another lookup function. The zone number was previously 
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retrieved from the Zones worksheet using the VLOOKUP function, and now will be used as the column 

number in a HLOOKUP to find the shipping charge. 

1. Click the Pricing sheet tab. In the Shipping Charge per Pound table, notice that the Zone numbers are 

displayed in blue and are arranged in ascending order from left to right. The Zone numbers match the 

column placement in this table, e.g. 2 at the top of the second column in this table. The weight ranges are 

arranged vertically in the first column of the table. To ship something that weighs 200 pounds or more 

but less than 500 pounds to zone 6 would cost $0.422 per pound as shown in Figure 8.30 

 

Figure 8.30. Shipping Charges are based on weight and zone. 

2. Select the range B14:L17. Click in the Name Box and type Shipping and then press Enter. You can also 

name a range by typing the name in the Name Box. Be sure to press Enter to set the name. 

3. Click the Invoice sheet tab and click cell G35. Write a formula to sum the weights in cells F22:F30. 

Format the cell in the Comma Style and two decimals. 

4. Click cell G38. On the Formulas tab, in the Function Library group, click the Lookup & Reference button 

and then click VLOOKUP. 

5. In the Lookup value box type G35—the weight that needs to be looked up. In the Table array box type 

Shipping—the name of the table range where the shipping value will be found, and in the Col index num 

box, type G37—the shipping zone which is used as the column index number. Click OK. The shipping 
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rate per pound—0.252— displays. 

6. To calculate the cost of shipping the weight needs to be multiplied by the shipping rate. Click cell G38, 

and then on the Formula Bar, click at the end of the formula and type *G35 and then press Enter. The 

total weight is multiplied by the shipping and handling fee retrieved from the Shipping table. Format the 

cell using the Accounting Number Format. 

7. In cell G39 sum the costs: =G31-G32+G34+G38. Compare your screen with Figure 8.31. 

 

Figure 8.31. Shipping Charges are based on weight and zone. 

8. Hold down the CTRL key and select cells A22:A30, D22:D30, and G33. Right-click on one of the 
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selected cells, and then on the shortcut menu click Format Cells. 

9. In the Format Cells dialog box, on the Protection tab, click the check box next to Locked to deselect it. 

Click OK. This unlocks these cells so that the worksheet can be used by others to create an invoice. 

10. On the Review tab, in the Changes group, click the Protect Sheet button. In the Protect Sheet dialog box, 

click OK. This protects the worksheet from someone overwriting the formulas you have created. Only the 

unlock cells can be used now. The rest of the worksheet is protected. 

11. Click cell A25. Click the list arrow and then click Copper roof flashing. In cell D25, type 60. Save your 

work. Compare your worksheet with Figure 8.32. 
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Figure 8.32. Revised invoice. 

Key Takeaways 
 To create a validation list from a named range, begin by naming a column of cells that contain acceptable answers. 

Select the cell that will use the list. On the Data tab, in the Data Tools group click the Data Validation button. In 

the dialog box, choose to allow values from a list. In the Source box, type an = sign and then the name of the range. 

[8.2.1] 

 To use VLOOKUP or HLOOKUP, begin by giving the table of data a name. If the VLOOKUP function is used, 

include the left column with row labels. If the HLOOKUP function is used, include the row with the column 
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headings. Both functions have three arguments; what to look up, the name of the table, and the column or row 

where the results will be found. In VLOOKUP and HLOOKUP the location of the result is a simple column or row 

number. Use the LOOKUP function if the unique data is not in the first column. Each column has its own name. 

LOOKUP has three arguments; the cell to look up, the column name in which to search, and the column name with 

the result. [8.2.2] 

 If a function refers to an empty cell, an error code displays. To suppress these codes, nest the function or formula 

inside the IFERROR( ) function. The IFERROR function has two arguments; what to do if there is no error, and 

what to do if there is. If the second argument is a pair of quotation marks with nothing between them, the cell will 

display nothing instead of the error message. [8.3.3] 

 If the column or row number needs to be looked up in a table and then that value used as an argument in another 

lookup function this can be done by nesting one of the lookup functions as an argument for another lookup function. 

[8.2.4] 

 To protect formulas on a complex worksheet, select the cells that may be used for input and remove the lock by 

right clicking, choosing Format Cells, Protection. On the Review tab in the Changing group, click Protect Sheet 

and then click OK. The entire sheet is protected except the unlocked cells. [8.2.5] 

3 Using Templates 

Learning Objectives 
1. Define and identify uses of templates. [8.3.1] 

2. Identify sources of templates. [8.3.2] 

3. Describe methods of creating, saving, sharing, and managing rights to templates. [8.3.3] 

4. Customize and save a template as a template file. [8.3.4] 

5. Open and modify an online template [8.3.5] 

A template is a pattern that is used repeatedly to create copies of the original. Templates are used in many 

industries and circumstances, such as patterns used to make clothes, machines that stamp out parts for 

automobiles, or forms used in business. In each case, the original pattern or template is preserved for 

repeated use. Excel can be used to design electronic versions of forms to accomplish various tasks. The form 
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is saved as a template and stored in a location such as a network drive, so that anyone who has access to the 

drive can use the form. The advantage of using a template is that it can be designed to meet the standards set 

by the company for tasks that need to be performed by many people. Using a standardized form insures 

consistency of layout and style and a uniform image for the company. As we saw with the invoice in the 

previous section, forms can be created so they are easy to complete and designed in such a way as to 

minimize errors. If the file is saved as a template file type in Excel with an .xltx extension, it is not easily 

overwritten by a version that has been filled in by a user. Instead the user simply saves the file by a different 

name and the original template is preserved. 

Excel has several installed templates that are available with the software and there are many others 

that are available online. The templates that come with the Excel software display when you click the File 

button and then click New, as shown in Figure 8.33. 
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Figure 8.33. Installed and online Excel templates found under File, New. 

A template can be created from scratch or modified from an existing template. Templates that are 

available online are fully designed and usually have built-in formulas. It is often necessary to look at several 

before you find one that will work for your purposes. Then you can customize the form, add or remove parts, 

reorganize the layout, and add your company’s name, logo, address, and other contact information. If you do 

not find a suitable template from Microsoft, a search of the Internet will locate many other options. Care 

must be taken to confirm that the source of templates is trustworthy because they might contain programming 

code that is not secure.  

After a template is modified, it should be tested to ensure that all the formulas work as expected. 

Testing it with people who will use the form is also a good idea to see that it is designed in a manner that is 

logical for the work flow. When the form is approved, it important to protect those parts of the form that you 

do not want the user to be able to change.  

Files that are saved as a template have an .xltx file extension which is different from the default Excel 

.xlsx file extension as shown in Figure 8.34. 

 

Figure 8.34. File extensions indicate how the file has been saved. 

By default files that are saved as a template are placed in a special Templates folder that is created 



   

 

Copyright ©2011 – John Preston Page 35 
 

when Excel is installed on a computer, as shown in Figure 8.35. 

 

Figure 8.35. Templates are saved in a Templates folder. 

When you open a template file that you have saved it is found by clicking the My Templates button in 

the File, New window as shown in Figure 8.36. 
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Figure 8.36. Templates are opened by clicking the My templates button. 

When you save a file as a template it needs to be in a location that is accessible to those who need to 

use it. Most companies require employees to log on to the company’s computer system using a user name 

and a password. Forms used by a company may be placed in a particular location that is only accessible to 

those with a particular security clearance. It is best to confer with the system administrator to determine the 

proper location and security level that is required to access electronic forms. In addition to protecting 

particular cells on the worksheet, you can also set a password to restrict access to the form at both the 

worksheet and workbook level. However, this level of security is typically reserved for sensitive information, 

not for forms that are used company-wide. The most important thing to protect on a form are the formulas so 

that it works as expected and does not result in errors because someone using the form typed something in 

the wrong place—overwriting a formula.  
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Files that are opened as a template display a number at the end of the file name which automatically 

gives it a file name that is different from the template file name. When you click the Save button, it will ask 

you if you want to save the changes. If you respond yes, the Save as dialog box will open and you will be 

required to save the form with a new name and in a new location as shown in Figure 8.37 

 

Figure 8.37. Templates that have been opened are given a new name by default. 

Saving a Workbook as a Template 

When a workbook is saved as a template the file extension is .xltx. Then when the template file is opened a 
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dialog box displays requiring that the file be saved with a new name. In this manner, the original template file 

is preserved and the new file is used for entering data. 

To see how this works, you will copy the Invoice worksheet to a new workbook and save that new 

file as a template. 

1. In Ch08TemplatesStudentName, click the Invoice sheet tab. Press and hold the Shift key and then click 

the Pricing sheet tab.  

2. Right-click the Invoice tab. Notice that the shortcut menu includes the Ungroup Sheets option. This 

indicates that you have successfully selected a group of sheets. 

3. From the shortcut menu click Move or Copy. 

4. In the Move or Copy dialog box, click the To book list arrow and then click (new book). Click the Create 

a copy check box and compare your screen with Figure 8.33. 

 

Figure 8.38. Invoice worksheet will be copied to a new workbook. 

5. Click OK. The new worksheet displays with the four selected worksheets. 

6. On the View tab, in the Window group click the Switch Windows button, and then click 
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Ch08TemplatesStudentName. 

7. Confirm that Ch08TemplatesStudentName still has all of its original sheets and then close the file. Save 

changes if prompted if you did not save the file at the end of the previous set of instructions. 

8. In the new workbook, on the Invoice sheet, select the items listed in cells A22:A25 and press delete. 

Delete the quantities in cells D22:D25 and the customer shipping information in cells G11:G15. Delete 

the tax rate in G33. 

9. On the Review tab, in the Changes group click the Unprotect button to remove the protection from this 

worksheet. 

10. Click cell B8 and look at the Formula Bar and notice that the TODAY function is used here to have the 

current date display. Another user might prefer to enter a date so this cell should be changeable by the 

user. 

11. With cell B8 as the active cell, hold down the CTRL key and select cells B9, B11:B15, G11:G15, 

A22:A30, D22:D30, and G33.  

12. On the Home tab, in the Cells group, click the Format button and then click Format Cells. In the Format 

Cells dialog box, click the Protection tab. The checkbox next to Locked displays a green square instead of 

a check or empty box, as shown in Figure 8.39. 

 

Figure 8.39. Mix of locked and unlocked cells have been selected. 

13. Next to Locked, click the check box twice to clear the box and unlock all of the selected cells, and then 

click OK. 
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Tip: An alternative to using the Format Cells dialog box is to use the Lock Cells option on the Format 
menu. When the selected cells are already locked the Locked Cells button will display with a border and 

shaded background. ; if a selected cells are unlocked, the shaded background does not display. . 
This button is a toggle button that makes it easy to switch the state back and forth from locked to 
unlocked. If a mixture of locked and unlocked cells is selected, it does not have an option for displaying 
this fact.  Instead, it displays the unlocked icon and will lock all of them if pressed. 

14. Notice the green triangle that displays in cell B8. Click B8 and read the ScreenTip that displays. Excel 

recognized that there are formulas in these cells and the cells are not locked. Click the Error Checking 

button next to the cell and from the displayed menu click Ignore Error as shown in Figure 8.40. This 

removes the green triangle from the corner of the cell. 

 

Figure 8.40. The Error Checking button is used to resolve potential errors. 

15. The #VALUE! and #REF! error notices display in cells G36:G39. They will go away when the first item 

is entered in the form and an address with a postal code is entered in G14. 

16. On the Invoice sheet, click in cell A22 and select an item from the list. In cell D22 type 10. In G33, type 

6. In cells G14, type Ypsilanti, MI 48197 

17. Confirm that the data all displays as expected in columns C, E, and F, and the formulas work in column 

G. 

18. Delete the entry in cell A22, D22, and G14.  

19. Click the Catalog sheet tab, hold down the Shift key and click the Pricing sheet tab to select the three 
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worksheets that are to the right of the Invoice sheet. Right-click one of the selected sheet tabs, and from 

the shortcut menu click Hide as shown in Figure 8.41. It is not necessary for someone who completes the 

invoice to see the underlying worksheets that contain the supporting information, so these worksheets can 

be hidden. 

 

Figure 8.41. Supported worksheets are hidden. 

20. On the Review tab, in the Changes group, click the Protect button. In the Protect sheet dialog box click 

OK. Do not enter a password. 

21. Now you are ready to save the workbook as a template. Click the File tab, and then click Save As. In the 

Save As dialog box, type InvoiceTemplateStudentName in the File Name box (using your own name). In 

the Save as box, click the list arrow, scroll the list and click then Excel Template. This will save the file 

with an .xltx extension. 

Tip: Notice that the Save in box displays Templates. If you save the file here it will displays as one of the 
Available Templates. This is accessed when you click File, New. However, the folder in which this is 
saved is often difficult to find on your hard drive. It also may not be the location where it should be 
saved on a company’s computer system. Always check the folder where a file is saved before clicking the 
Save button so you do not lose track of your files.  

22. Click the Save in list arrow and navigate to the folder where you are saving your files for this class, then 
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click Save. The file is saved in your folder as a template. 

Modifying an Online Template 

 

There are numerous templates that are available online for a variety of purposes. It is often easier to start with 

a design and modify it as necessary to meet your specific purposes.. 

To see how this works, you open and modify an online expense report template. 

1. Open Excel. Click File, and then click New. Under Office .com Templates, click Reports. In this list of 

folders that display click Financial reports to display the contents. 

2. Click on several different reports. A larger image displays at the right of the screen along with a 

download button as shown in Figure 8.42. 



   

 

Copyright ©2011 – John Preston Page 43 
 

 

Figure 8.42. Templates are categorized in folders. 

3. On the toolbar under Available Templates click the Back arrow two times to return to the first list of 

folders. 

4. Click the Invoices button and click the Estimates folder. Click the Job Estimates template as shown in 

Figure 8.43 

 

Figure 8.43. Template selected for download. 

5. Click the Download button. The template opens as the only worksheet in a new workbook. It has sample 

data entered to demonstrate how the form should be used. Also notice that the gridlines and row and 

column headings do not display. 

6. Point to the red triangle in the cell below City, State Zip. A comment has been added to this cell to 

explain how the form should be used as shown in Figure 8.44. 
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Figure 8.44. Comment used to explain purpose of template. 

7. On the View tab, in the Show group, click the Gridlines check box, and the Headings check box to 

display both of these elements. 

8. Click cell C3 and replace the company name by typing Ypsilanti Sunshine. Select cells C3:G3 and on the 

Home tab in the Font group, click the Fill Color button arrow. Under Standard Colors, click the third 

color—Orange. Click the Font Color button arrow and in the column of green colors, click the last 

color—Olive Green, Accent 3, Darker 50% as shown in Figure 8.45. 
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Figure 8.45. Font color changed. 

9. In cells C4:C6, replace the company address with the following: 

122 Sill Street 

Ypsilanti, MI 48197 

Phone (734) 555-0190 

10. Delete the placeholder phone number in cell F7.  

11. In cell C10 type your name and in cell C11 type Company Name 

12. Delete the text entered in the Job Description box—cells C18:C19, and in the Itemized Estimate box—

cells C23:C26. 

13. Click cell J23 and apply the Accounting Number Format. Select cells J24:J33 and apply the Comma Style 

format. Delete the contents in cells J23:J26. 

14. Click cell J34 and apply the Accounting Number Format. Examine the IF statement in the Formula Bar as 

shown in Figure 8.46. This statement has been used to sum the contents of the column if there is a sum, 

otherwise cell J34 will be blank. This is another method for avoiding the #NA error that would otherwise 

display because cells J23:J33 are now blank. 
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Figure 8.46. IF function used to sum column J. 

15. On the View tab, in the Show group, clear the checkmarks next to Gridlines and next to Headings to 

remove the gridlines and column and row headings from this worksheet. 

16. Open the Ch08TemplatesStudentName file.  

17. On the View tab, in the Window group, click the Switch Windows button and then click 

Jaxworks_JobEstimate1 to switch to the Job Estimate template. This file could be saved as a separate 

template file, but you will move it to the Ch08Templates workbook to submit for grading. 

18. Right-click the Job Estimate sheet tab and then click Move or Copy. Change To book to 

Ch08TemplatesStudentName. Click (move to end). Confirm that the Create a copy option is not selected, 

and then click OK. The worksheet is moved. The Jaxworks_JobEstimate1 workbook has no content so it 

ceases to exist. 

19. Save the Ch08TemplatesStudentName file and close it. 

20. Submit the Ch08TemplatesStudentName.xlsx file and the InvoiceTemplateStudentName.xltx file in the 

usual manner. 

Key Takeaways 
 In Excel templates are predesigned forms that can be used for a wide variety of business purposes, which are made 
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available to many users.[8.3.1] 

 Templates can be created from scratch, or be a modified version of an online template from Microsoft or from 

another provider. [8.32] 

 Templates are shared by placing them in a location on a computer system that is accessible by numerous people. 

Saving a file as a template places it in a Templates folder by default which makes it available from the File, New, 

My Templates window. Rights can be controlled by adding a password to the file, or by placing the file in a location 

that requires a user logon and password. [8.33] 

 Formulas in a template should be protected from unauthorized change by locking those cells. Cells that require 

user input should be locked and then protection applied to the worksheet. After the file is tested it is saved as a 

.xltx file. [8.3.4] 

 Online templates can be downloaded from the File, New window and then customized to include company 

information and specific needs of the organization. [8.3.5] 

Key Terms  

HLOOKUP 

A function that is used to retrieve data from a horizontally arranged table where the value that is looked 

up is in the first row of the lookup table. 

Invoice 

A financial form that is a list of goods sold to a customer. 

LOOKUP 

A function that is used to retrieve data from a table where the value that is looked up is not in the first 

column of the lookup table. 

Nesting 

When one function used as an argument within another function. 

Scope 

An option that enables you to control whether a name range applies to a single worksheet or an entire 

workbook. 

Template 

A form or worksheet that is designed for a particular purposed and thens saved as a template file so that it 
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can be used repeatedly by many different people. 

Validation 

A list of acceptable values or ranges of acceptable values 

VLOOKUP 

A function that is used to retrieve data from a vertically arranged table where the value that is looked up 

is located in the first column of the lookup table. 

Workbook 

A spreadsheet file in Excel. 

Worksheets (sheets) 

Individual pages or sheets in an Excel workbook 
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